Back to overview
Degraded

Microsoft Azure Issues

Oct 29 at 05:16pm CET
Affected services
Europe
North and South America
India

Resolved
Oct 29 at 11:00pm CET

Most of the services are recovered and AERO is fully working again.

Updated
Oct 29 at 08:40pm CET

Microsoft expects full recovery of the services by 23:20 UTC on 29 October 2025. We will provide another update on our progress within two hours, or sooner if warranted.

Updated
Oct 29 at 07:58pm CET

According to Microsoft, they where able to identify the issue and we are expecting a recovery of our services within the next 1,5 hours.

Created
Oct 29 at 05:16pm CET

We are currently experiencing issues with Microsoft Azure that are affecting the availability of AERO. Our team is actively monitoring the situation and working closely with Microsoft to ensure service is restored as soon as possible.