Back to overview
Degraded

AERO Dashboard availability is limited based on user location

Apr 2, 2026 at 9:17am UTC
Affected services
Europe

Resolved
Apr 2, 2026 at 10:39am UTC

Access to the AERO Dashboard is now fully restored and functioning normally.

No data was impacted at any time.

Our team is currently in contact with Microsoft Support to perform a root cause analysis.

We will share further information if relevant updates become available.

Created
Apr 2, 2026 at 9:17am UTC

Our monitoring has detected that AERO Dashboards are currently not accessible from certain locations, including Switzerland, France, UK.

AERO services remain fully operational. The issue only affects access to the dashboards and appears to be related to the location from which a user is attempting to log in.

We are closely monitoring the situation and investigating it with high priority.

We will share further updates as soon as more information becomes available.