Back to overview
Resolved

AZURE Issue affecting Xovis Data

Jul 11, 2026 at 7:08pm UTC
Affected services
Europe

Resolved
Jul 13, 2026 at 2:29pm UTC

We are happy to inform that the issue could be identified and successfully resolved. All dashboards are fully working again.
We are now working on understanding the incident together with Microsoft in more detail. A post mortem review will be available within the next 14 days latest.
Please contact Xovis Support for more details.

Updated
Jul 12, 2026 at 6:58pm UTC

Microsoft report again similar issues which is affecting certain Dashboards. We apologize for the inconvenience and thank you for your understanding.

In case of questions, please reach out to Xovis Support.

Created
Jul 11, 2026 at 7:08pm UTC

Dear Customers
We would like to inform you that there is currently an incident affecting the Microsoft Azure platform, which is impacting our data processing.

The root cause has been identified as an Azure platform issue that is outside of our control. As a result, some dashboards may currently show missing or delayed data.

Microsoft is actively working to resolve the incident. We are closely monitoring the situation and will keep you informed as soon as the service has been fully restored or if there are any significant updates.

We apologize for the inconvenience and thank you for your understanding.

Best regards,

Xovis Support